S'identifier - S'inscrire - Ecrire un article - Contact

Nouvel éditeur visuel : FCKeditor -- MAJ du 11/10

Par Stephane • Actualités • Mardi 09/10/2007 • 96 commentaires  • Lu 9003 fois • Version imprimable

Mots-clés :


Le vieil éditeur visuel de ViaBloga basé sur HTMLarea qui n'était plus maintenu a été remplacé par FCKEditor. FCKEditor était en test depuis quelques mois, et je pense que la plupart des problèmes ont été résolus. N'hésitez pas cependant à me signaler d'éventuels mauvais fonctionnements dans certains formulaires et/ou avec certains navigateurs.

EDIT isabelle (petit résumé des astuces données en commentaires ici et )
- possibilité de redimentionner une image directement dans l'éditeur
- possibilité d'aller chercher une image dans le dossier images de son blog sur le serveur VB (image ayant déjà été téléchargée auparavant)
- propriété d'une image en cours d'édition : clic droit (ou ctrl + cloc droit sous mac)
- pour retour à la ligne sans interligne : "shift" + "entrée" (shift = maj)
- pour effacer le format d'une police (taille ou couleur) et revenir au format par défaut: le bouton gomme
- pour une citation : le bouton retrait de paragraphe
- pour modifier un tableau (lignes, colonnes, cellules, propriétés) : clic droit (ou ctrl + cloc droit sous mac)
- pour défaire un mot-clé : le bouton qui enlève les liens
- nouveautés : table de caractères spéciaux et smileys
- pour insérer un fichier : bouton insérer un lien, onglet "Télécharger" et possibilité de modifier le titre

D'autres articles sur des thèmes similaires :


Commentaires

par isabelle le Mercredi 10/10/2007 à 00:31

isabelle

Est-ce que Delphine va avoir lun moment pour nous mettre à jour son tuto ? Il est bien pratique pour les nouveaux. Les commentateurs qui ont l'habitude d'autres plateformes sont souvent étonnés en découvrant les possibilités offertes pour l'édition de leurs commentaires.


nouvel éditeur par bapceres le Mercredi 10/10/2007 à 03:22

Surprise !!!!!!!

Comment ça marche ??????????

Impossible inserrer image !!!!

N'étant spécialistes nombreux vont être les clients de Viabloga à se trouver embarrassés  par cette nouveauté s'il n'y a pas un mode d'emploi.

Prière d'expliquer sommairement le nouveau  fonctionnement.

Comment touver ses images, les inserrer, etc.........


Re: nouvel éditeur par Stephane le Mercredi 10/10/2007 à 11:23

Stephane

-> bouton "Insérer/Modifier une image", onglet "Télécharger".


Re: nouvel éditeur par bapceres le Vendredi 12/10/2007 à 04:34

PROPUPS ,,,,???????????????????????!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Comment activer ou désactiver ?

 

 


Re: nouvel éditeur par isabelle le Mercredi 10/10/2007 à 12:36

isabelle

merci au passage pour cette illustration du rayonnement horizontal des étoiles en petite colonne


retour à la ligne sans interligne ? par isabelle le Mercredi 10/10/2007 à 11:02

isabelle

Comment fait-on pour aller à la ligne sans avoir un interligne : la touche entrée insère la balise  p automatiquement et pas simplement br. Quand on a besoin d'écrire une suite de mots à la ligne en petite colonne (pour des liens par exemple) ça double pratiquement la hauteur du texte.


Re: retour à la ligne sans interligne ? par OlivierMG le Mercredi 10/10/2007 à 11:10

OlivierMG il faut appuyer sur "shift" + "entrée"


Re: retour à la ligne sans interligne ? par Caroline le Mercredi 10/10/2007 à 12:19

"shift" + "entrée", Olivier, tu es sûr ? Moi qui étais ravie de ta combine, ça ne marche pas chez moi. Il ne se passe rien, ça ne va pas à la ligne.

EDIT - Mais si, ça marche ! Sorry... et merci à Isabelle pour son résumé des commentaires à la fin de l'article de Stéphane.


espace en début de commentaire par isabelle le Mercredi 10/10/2007 à 11:05

isabelle

Idem pour les commentaires : il y a automatiquement un grand espace avant le début du texte, imposible de l'enlever...


Re: espace en début de commentaire par OlivierMG le Mercredi 10/10/2007 à 11:20

OlivierMG

ceci-dit, moi je l'aime bien ce retrait en début de commentaire (regarde mon précédent commentaire : j'ai enlevé le retrait en retirant les balises P du code source, et je trouve ça moins joli finalement ! ..par contre s'il fait ça aussi pour les articles...)


Re: espace en début de commentaire par isabelle le Mercredi 10/10/2007 à 11:25

isabelle

C'est pas génial pour les commentaires sans trombine ;-)


Re: espace en début de commentaire par OlivierMG le Mercredi 10/10/2007 à 11:28

OlivierMG

au fait, tu as essayé les fonctions d'insertion d'image/photos dans un commentaire ou un article ?


Re: espace en début de commentaire par isabelle le Mercredi 10/10/2007 à 11:36

isabelle

oui, j'ai un peu cherché pour insérer une image, il faut ouvrir l'onglet "Télécharger" de l'éditeur d'image pour trouver l'habituel "Parcourir", l'onglet d'arrivée étant pour les images déjà sur le serveur. Et on peut facilement disposer les texte comme on veut.

Est-ce qu'il serait possible de traduire le petit message après la validation de l'image, il est encore en anglais.

Ce qui n'est pas facile, c'est la différence de rendu entre la cadre où on écrit et le texte validé, à cause de la modification de largeur de la colonne. Par exemple cette dernière phrase était à droite de l'arbre dans le brouillon...


Re: espace en début de commentaire par leblase le Mercredi 10/10/2007 à 11:44

leblase

ça ne se passe pas tout seul.

Tu tombes sur une feuille chargée de tous les fichiers images d'un dossier inconnu (j'e suppose qu'en l'occurence c'était celui de VdeV mais imagine dans le cas du shplouc!) ensuite tu dois trouver quel serveur, quel dossier, quel upload correspond à la chtite photo qui est dans ton dossier, et que tu voudrais mettre puis surtout ne pas cliquer sur l'option par défaut mais sur l'onglet télécharger.

Après ça, ben comme on l'a déjà fait remarquer, la légende est déparée par une interligne.

 

Trop de manipulations par rapport aux 2 systèmes précédents.

De plus (là par exemple j'aurais aimé comme c'était le cas avant, quand tu décochais le bouton alignement central, revenir automatiquement à la couleur de base), mais queude.

Je crains un mouvement social de la part des commentateurtrices, et la diligence pour Varennes est déjà partie!


Re: espace en début de commentaire par isabelle le Mercredi 10/10/2007 à 11:58

isabelle

Ce qui m'ennuie beaucoup, c'est de savoir qui a accès au seveur de cette façon ?


Re: espace en début de commentaire par leblase le Mercredi 10/10/2007 à 12:03

leblase

Isabelle,

Voilà une remarque fort pertinente.

Je suppose que le Sorcier y a réfléchi, mais?


Re: espace en début de commentaire par Stephane le Mercredi 10/10/2007 à 12:26

Stephane

A la liste des images ? Pour l'instant tout le monde. Je vais essayer de rendre ça configurable via les permissions.


Re: espace en début de commentaire par Stephane le Mercredi 10/10/2007 à 12:03

Stephane

> Je crains un mouvement social de la part des commentateurtrices, et la diligence pour Varennes est déjà partie!

Il faut bien que je change des trucs de temps en temps pour vous donner un prétexte pour râler.

Le bouton "supprimer le format" est hyper pratique pour enlever le violet que tu as mis. ;-)


Re: espace en début de commentaire par leblase le Mercredi 10/10/2007 à 12:13

leblase

je commence comme ça, j'appuie sur la gomme et miracle!

Sorcier, toi être grand (je mets le smiley pour faire plaisir à OlivierMG)!

Râler, moi? Mince, y a pas de Smiley râleur!!


ouf ! par isabelle le Mercredi 10/10/2007 à 11:27

isabelle

non, non pas pour les articles...


couleur de texte "automatique" par isabelle le Mercredi 10/10/2007 à 11:08

isabelle

Je commence à écrire en rouge, mais je m'aperçois que j'en ai trop mis, je veux revenir à la couleur par défaut, rien ne se passe avec la touche "automatique".

 


Quote par olivier le Mercredi 10/10/2007 à 11:26

Il n'y a plus le petit bouton "citation"...

Snif....


Re: Quote par Stephane le Mercredi 10/10/2007 à 12:01

Stephane

Il n'y a plus le petit bouton "citation"...

 

Je ne l'ai pas mis car le bouton "Augmenter le retrait" fait la même chose.

 


Re: Quote par olivier le Mercredi 17/10/2007 à 19:55

Ah non, sur certains design le "citation" te passe en italique et ajoute 1 beau guillemet au début.
Ct chouette


Re: Quote par Stephane le Mercredi 17/10/2007 à 20:01

Stephane Il y a maintenant un nouveau bouton citation. ;-) (en test sur V2V, bientôt partout)


Re: Quote par olivier le Vendredi 26/10/2007 à 09:53

je ne le vois pas...


Re: Quote par olivier le Vendredi 26/10/2007 à 09:54

comme d'hab je parle trop vite.... trouvé


le temps qu'il faut par leblase le Mercredi 10/10/2007 à 11:29

leblase

Je le trouve un peu plus lent que l'autre, mais peut-être n'est-ce qu'une impression..

Je partage l'avis d'Isabelle concernant les interlignes. Et même si Olivier nous a donné une solution, ce serait bien de pouvoir le paramétrer automatiquement pour éviter cette interligne.

Une question bien typique: quelle est la différence entre les 3 "coller (coller; coller de texte; coller de Word)

Reste t'il une option "citation"?

A quoi sert "Supprimer le format"(la gomme)?

A quoi sert "l'édition pleine page"?

Ce sera tout pour le moment


Re: le temps qu'il faut par OlivierMG le Mercredi 10/10/2007 à 11:33

OlivierMG

mort de rire pour le smiley (leblase qui utilise un smiley !!! ;-) et pour le "quel site ?" de stéphane !

oui, de mon côté aussi, je le trouve plus lent.
pour la citation, il est possible d'utiliser l'icône de retrait de paragraphe, bien que ce ne soit pas tout à fait la même chose...

 


Re: le temps qu'il faut par Stephane le Mercredi 10/10/2007 à 12:02

Stephane

Plus lent pour faire quoi ?


Re: le temps qu'il faut par leblase le Mercredi 10/10/2007 à 12:08

leblase

Son affichage me parait plus lent.

Ensuite, les opérations d'insertion nécessitant, comme je le disais plus haut, plus d'opérations, cela ralentit  "l'écriture automatique" telle que Viabloga le permet dans des discussions croisées de réponses à commentaires (je n'imagine pas que ce genre de truc n'existe que sur le shplouc)

D'autre part, mais peut-être est-ce seulement sur l'ordi que j'utilise en ce moment, le bouton "valider" est limite limite bas d'écran


Re: le temps qu'il faut par Stephane le Mercredi 10/10/2007 à 12:25

Stephane

Une fois l'éditeur en cache, il met moins d'une seconde à s'afficher. Je ne pense pas que ca soit plus lent que l'autre.


Re: le temps qu'il faut par Stephane le Mercredi 10/10/2007 à 12:04

Stephane

Réponses pour les à quoi sert truc :

Appuis sur truc, tu verras bien.


Ajout de Georgia, chiffres pour les tailles par Stephane le Mercredi 10/10/2007 à 12:16

Stephane

A la demande de Camille, j'ai ajouté Georgia dans la liste des polices. J'ai aussi mis des chiffres dans les libellés des tailles.


Citation / Augmenter le retrait par Caroline le Mercredi 10/10/2007 à 12:28

Moi j'adore la possibilité de redimensionner les photos directement dans la fenêtre d'importation, c'est génial.

Et la table des caractères spéciaux.

Je vois que certains regrettent la disparition de la fonction citation, moi je regrette uniquement celle de l'icône correspondante et de son appellation : car la fonction, elle, existe toujours ! Mais désormais sous l'intitulé, à mon avis inapproprié, "augmenter le retrait".
Je regrette vraiment l'absence d'une fonction correspondant réellement à "augmenter le retrait". Car en cliquant sur "augmenter le retrait", je veux juste, comme le nom de la fonction l'indique, un décalage du paragraphe : c'est très exactement cela que je désire, et pas davantage ; or, actuellement, je récolte en prime une mise en forme archi spécifique (changement de style de caractère qui passe en italique + filet vertical à gauche du paragraphe mis en retrait), qui dépasse de loin mon intention et qui ne me convient donc pas, mais qui correspond très exactement à l'ancienne fonction "citation".


Re: Citation / Augmenter le retrait par Stephane le Jeudi 11/10/2007 à 11:39

Stephane

> Moi j'adore la possibilité de redimensionner les photos directement dans la fenêtre d'importation, c'est génial.

Attention, ça ne redimensionne pas vraiment l'image, ca change sa taille d'affichage. A utiliser _très_ modéremment.


Re: Citation / Augmenter le retrait par Caroline le Jeudi 11/10/2007 à 11:47

Caroline

Je saisis mal la nuance. 

Et pourquoi il faut l'utiliser très modérément ? A moins que ce ne soit une question de taille mémoire inchangée, c'est ça ?


par isabelle le Mercredi 10/10/2007 à 13:27

isabelle

je me suis permise une petite synthèse des commentaires dans l'article même


par iza le Mercredi 10/10/2007 à 14:45

panique à bord de mes blogs....

où puis je trouver l'équivalent du trombone (inserer des Mp3 et avoir le player intégré, tout bien comme il faut)...

???


Re: par Stephane le Mercredi 10/10/2007 à 15:01

Stephane

test


Re: par Stephane le Mercredi 10/10/2007 à 15:02

Stephane

bouton "Insérer un lien", onglet "Télécharger"


par iza le Mercredi 10/10/2007 à 15:25

ok, vu, ça marche merci.

Par contre, comment mettre un titre autre que la longue ligne de l'adresse au dessus ? J'ai essayé plusieurs trucs, et ça ne donne rien; Merci d'avance (et la rapidité ! exceptionnelle ! je reviendrais ) (je teste un peu les smileys au passage..


Re: par Stephane le Mercredi 10/10/2007 à 15:27

Stephane

Ben tu vas sur le titre et tu mets ce que tu veux à la place. ;-) L'important est de ne pas l'effacer completement d'un seul coup afin de garder le lien vers le fichier.


insertions problématiques par leblase le Mercredi 10/10/2007 à 17:31

leblase

Laseine écrit un message et insère une image.

Le résultat est que  sur mon modèle 2colonnes l'article et les commentaires (en colonne de droite) disparaissent totalement  et que je retrouve une partie de son image et commentaire, plus "répondre à ce commentaire" et "modifier" en bas, couvrant la fin de la colonne de gauche.

le code de son message est :

<p>Archi,<br />
<br />
le disours de Dakar a eu le mérite minime de nous montrer de manière claire que</p>
<p align="center"><img width="293" height="399" class="" alt="" src="http://leblase.net/images/BHL_guaino_1_t.jpg" /><br />
BHL voit clair dans Guaino et Gaino voit clair dans BHL</p>


Re: insertions problématiques par Stephane le Mercredi 10/10/2007 à 18:59

Stephane

Il manque un </p>, il a du taper le code à la main. ;-)

Normalement j'ajoute les </p> manquants cependant. Quelle est l'url de ce commentaire ?


Re: insertions problématiques par leblase le Mercredi 10/10/2007 à 20:53

leblase

Ben, j'ai été obligé de l'effacer... C'était dommage d'ailleurs arce que la photo avait l'air bien.

Je vais le lui signaler. Tu avais raison pour l'éditeur: il monte plus vite maintenant.


Re: insertions problématiques par leblase le Vendredi 12/10/2007 à 13:21

leblase

Tiens, justmeent je me souvenais que tu mettais des /p...

l'url qui me pose un problème est le:http://leblase.net/cgi-bin/comments.pl?site_id=leblase&news_id=100&comment_id=158&


Insertion d'image par Stephane le Mercredi 10/10/2007 à 20:52

Stephane

J'ai ajouté le formulaire d'envoi d'image en haut de l'onglet principal du dialogue "Insérer une image". Ca économise un clic, et c'est probablement bien plus fréquent qu'aller repêcher une image dans les dossiers du blog.


Re: Insertion d'image par leblase le Mercredi 10/10/2007 à 20:54

leblase

Good move, comme on dit en Nouvelle-Zélande


Re: Insertion d'image par Fix le Jeudi 11/10/2007 à 02:12

Fix

Good move, mais à quoi sert l'onglet "télécharger" ?

Onglet "Télécharger"
Onglet "Télécharger"

because dans cet onglet, quand on "parcourt" puis qu'on "envoie sur le serveur", ça produit un message d'erreur :

Erreur "no file upload"
Erreur "no file upload"

... et en globish, en plusse :-)

Ce que je trouve très dommage, c'est qu'il n'y ait plus d'onglet "avancé",

Dans cet onglet "avancé", on pouvait, en particulier, mettre une balise titre (tooltip), ce qui fait qu'un texte s'affiche lorsqu'on survole une image avec le pointeur de la souris. Comme punition, chers lecteurs, vous êtes privés de "tooltip" sur les images de ce comm'. Oh bien sûr je pourrais passer en HTML et le faire à la main, mais .... je suis raisonnablement paresseux, comme se doit de l'être tout VB-iste qui se respecte.

Onglet "avancé"
Onglet "avancé"

Et je ne retrouve pas non plus l'onglet "lien".

Zut. Et je n'ai pas fabriqué à temps de copie d'écran, peux donc pas mettre d'image.

 

Bon, dans tout ça, que devient  ...

... ce suuuuuuperbe début de commencement de tutoriel sur l'éditeur visuel - en ce qui concerne les images ? Si "on"  sucre les z'onglets et possibilités, où ça va, dites, ho ? (Nota : au moins, dans l'éditeur de liens, l'onglet "avancé" est toujours là alors que je rédige ce comm', les lecteurs peuvent donc lire un "tooltip" absolument factuel en survolant le lien avec le pointeur de la souris).

Voilà ce que c'est que de faire du zèle en se mettant à faire un tuto :-)

 

 


Re: Insertion d'image par Stephane le Jeudi 11/10/2007 à 11:45

Stephane

J'ai fait exprès de supprimer les onglets liens et avancés qui ne sont pas d'une très grande utilité. (en gros ils apportent plus de confusion que de bénéfices)

Pour la balise titre, faut voir. On pourrait l'ajouter à la page, en dessous de texte de remplacement. Ou mettre les alt en title aussi.

Je voulais aussi supprimer l'onglet télécharger, mais je n'ai pas encore réussi.

 

 


par Iza le Mercredi 10/10/2007 à 22:53

Iza

mouaich, c'est cette subtile nuance :"L'important est de ne pas l'effacer completement d'un seul coup afin de garder le lien vers le fichier." que je n'ai pas bien compris.

Quand tu dis le titre, tu parles bien de l'onglet "info sur le lien" et donc de l'emplacement "url" ?

C'est quoi, "pas effacer complètement d'un seul coup ????" moi pas saisir...


petit soucis de profil par isabelle le Mercredi 10/10/2007 à 23:21

isabelle

Iza, tu as dû arriver ici directement de ton blog avec le lien 'Aller au site des utilisateurs". Mais comme il est privé, V2V demande le code d'accès pour que la trombine de ton commentaire qui est sans doute issus de ton profil sur ce blog privé s'affiche ici. Et ce, à chaque fois qu'un lecteur ici veut ouvrir la page de cet article. Accepteraids-tu de te créer un profil directement sur V2V et de l'utiliser quand tu veux écrire ici, sinon on va avoir ce problème à chacune de tes interventions. Merci à toi :-)


Re: petit soucis de profil par Fix le Jeudi 11/10/2007 à 02:49

Fix

Quelle est la "déontologie" de modération de VdeV dans ce cas ? En attendant que "Iza" fasse la manoeuvre souhaitée par Isabelle, serait-il correct de :

1) créer un profil "Iza" avec un mot de passe provisoire -

2) copier le commentaire de "Iza"

3) effacer le commentaire

4) re-créer le commentaire en signant avec le profil "Iza" de VdeV

5) demander au Grand Gourou qui peut tout et sait tout (en particulier le mail de "Iza", lors de la création du blog de cet utilisateur/trice), d'envoyer un mail à "Iza" pour lui demander de valider son profil sur VdeV - et de changer par la même occasion son mot de passe.

Les étapes 1 à 4 sont uniquement destinées à éviter le message perturbant qui demande de s'identifier pour accéder au blog de "Isa", et qui s'affiche à chaque nouvel affichage de l'article que vous lisez.

 

On peut aussi réfléchir à une suggestion à faire sur VdeV : lorsque un utilisateur vient d'un blog privé vers VdeV et rédige quelque chose, que le nécessaire soit fait pour qu'un message "perturbant" ne s'affiche pas pour les autres utilisateurs.

 

 


Re: petit soucis de profil par Stephane le Jeudi 11/10/2007 à 10:16

Stephane

Et le nécessaire fut fait.


Re: par Stephane le Jeudi 11/10/2007 à 11:47

Stephane

1. tu ajoutes le fichier

2. de retour dans l'édition du texte, tu change le texte du lien


Boutons "aligné à gauche/à droite" et "centré" : inopérants dans le modèle Déclic par Caroline le Jeudi 11/10/2007 à 11:10

Caroline

Qu'on choisisse "aligné à gauche/à droite" ou "centré", le texte obéit à l'ordre sur le moment mais, une fois enregistré, il sort uniquement en mode justifié.

J'ai essayé dans d'autres modèles, Green Park et Minimum : là pas de problème, ça marche.

J'ai réessayé plusieurs fois dans Déclic, après avoir relancé Firefox, ça ne marche toujours pas.

 

Exemple :

• Voici ce que j'ai tapé :

 

• Voici ce que j'obtiens à l'affichage après l'enregistrement :

 

• Voici le code source, si ça peut aider :

Plus lisiblement :

<p>kgfmxdflgmùdqf`glqm`ùdfg</p>
<p align="center">jkxdlgjksqdglùmqsjdfqlùdfg</p>
<p align="right">sdfgjkqlskglqsdgqlmsd</p>
<p align="justify">sdjfkqsldjgmjsdglqùdg djgkrsdlmqshfd&#160; pfgk plropert pldfttk d lrmgkerl gkeqlrt qelrgkqelmerkgqèrlgmqelrtk</p>


NB. L'éditeur ne s'affiche ni sous Safari (2.0.4) ni sous IE (5.2). Du coup, impossible de tester et impossible de m'en sortir autrement que sous Firefox.


Re: Boutons... --- résolu par Caroline le Jeudi 11/10/2007 à 11:35

Caroline

C'est bon, j'ai trouvé : il faut taper <div align=... au lieu de <p align=... dans le code source.

En fait, il y a quand même vachement plus de boulot dans le code source, par rapport à avant, c'est le seul défaut du nouvel éditeur. Trop de trucs imposés automatiquement, à dépolluer sans cesse. Je trouvais plus motivant l'ancien éditeur, où on était incités à aller dans le code source pour trouver des améliorations de mise en forme perso, pas pour aller déminer et résoudre des problèmes qu'on n'avait pas demandés.

Sinon, c'est bien, surtout pour les images.

(Merci à celui qui supprimera mon commentaire 46 qui n'a rien à faire ici, d'autant que j'ai trouvé un autre endroit mieux approprié où poser ma question, et merci d'avance à celui qui aurait une solution en tête pour y répondre.)


Re: Boutons par Stephane le Jeudi 11/10/2007 à 11:49

Stephane

C'est un pb avec Declic je pense.

Test centré.

Test gauche.

Test droit.

Normal.

 

En fait Declic doit forcer le justify avec le CSS, ce qui est une idée moyenne. Je vais l'enlever.


Re: Boutons par Jean-Luc le Jeudi 11/10/2007 à 12:11

Jean-Luc

Soit dit en passant, c'est aussi le cas avec Ondine. Que modifier dans la CSS ?


Re: Boutons par Stephane le Jeudi 11/10/2007 à 15:40

Stephane

Ben tu cherches "justify", et tu l'enlèves. ;-)

Y en a qu'un :

#content .post p{
        margin: 1em 0;
        text-align: justify;
}


Re: Boutons par Jean-Luc le Dimanche 14/10/2007 à 16:40

Jean-Luc

Je n'ai pas été assez précis dans la formulation de ma demande. En fait je voudrais que cela puisse être toujours justify par défaut mais que lorsque qu'on choisit right ou left via l'éditeur ou en mode html, cela soit appliqué. Seulement la définition CSS prévaut en dernier lieu  et ce n'est donc probablement pas la bonne méthode. Autant dire qu'il n'y a pas de solutions, n'est-ce pas ? Auquel cas je continuerai de remplacer "à la main" les balises <p align="right"> ou <p align="left"> par les div correpondantes quand de besoin.


Re: Boutons par Stephane le Jeudi 11/10/2007 à 12:00

Stephane

NB. L'éditeur ne s'affiche ni sous Safari (2.0.4) ni sous IE (5.2).

Oui, aucun éditeur visuel ne fonctionne avec IE 5.2 qui n'a pas évolué depuis le 27 mars 2000. (cf wikipedia )

L'éditeur est censé marcher avec la nouvelle version de Safari (3).


Re: Boutons par leblase le Jeudi 11/10/2007 à 19:51

leblase

Héhé!

Je me disais bien qu'il fallait abandonner Netscape 1.1

A part çà, personne n'est gêné de voir le bouton "valider" quasiment hors cadre en bàa d'écran?


Re: Boutons par isabelle le Jeudi 11/10/2007 à 20:16

isabelle euh, bien non, il n'y a aucun bouton. Mais peut-être qu'il fallait installer des machins en plus, mais comme tout est en english...


par isabelle le Jeudi 11/10/2007 à 21:47

isabelle

Quand on choisit "coller de word" l'éditeur ne garde rien du format des polices, dommage !


Re: par belinunda le Samedi 13/10/2007 à 10:40

Oui, ca fait pas tres beau. Du coup, ce n'est plus harmonieux.... C'était bien quand on pouvait choisir la taille de police (10, 12), du coup la il y a des différences de taille entre les articles, j'ai l'impression (voir exemple sur mon blog entre les 2 premiers articles)... Ca fait pas très pro..

http://blog.consommerdurable.com/


Re: par Stephane le Samedi 13/10/2007 à 14:42

Stephane

Ben tu peux toujours choisir la taille.


Re: par belinunda le Samedi 13/10/2007 à 15:09

C'est la même taille qui ressort ? Un x-small 2 par exemple coresspond à une taille 10 ?


Re: par Stephane le Samedi 13/10/2007 à 15:32

Stephane

Ca correspond à un font-size=2. Exactement comme dans l'autre éditeur.

En fait depuis deux jours, il y a une nouvelle version de FCKeditor qui permet de mettre des styles CSS pour les tailles etc. Du coup on devrait pouvoir mettre des tailles en pixels.


par belinunda le Samedi 13/10/2007 à 15:51

Super merci beaucoup.

 


Problème d'incorporation vidéo par dalotel le Samedi 13/10/2007 à 16:19

Bonjour,

Dans le nouvel environnement Viabloga.

En cherchant à écrire un nouvel article je me confronte au probléme suivant : je n'arrive pas à incorporer mes vidéos comme avant. NB ( j'ai juste testé dans les brouillons ).

1. Je la télécharge et je la retrouve bien dans mes fichiers.
2. Lors de la rédaction de l'article, l'adresse lien s'inscrit bien.
3. Mais lors de la publication dans brouillon elle reste inscrite en adresse lien, et elle ne n'apparait pas directement, prète à être visionnée.

Je bloque !

Je me trompe peut être de procèdure, merci d'avance de bien vouloir m'indiquer quoi faire.

François


Re: Problème d'incorporation vidéo par Stephane le Samedi 13/10/2007 à 17:53

Stephane

C'est un bug avec le convertisseur de vidéos en fait, c'est indépendant de l'éditeur. Je répare.


Re: Problème d'incorporation vidéo par dalotel le Samedi 13/10/2007 à 18:54

Merci Stéphane

Pour ta réponse très rapide et l'efficacité.
Je viens de faire l'essai et tout est OK, la vidéo passe.

Encore merci et bravo pour l'ensemble de Viabloga.

François

 


Icônes par Didier le Dimanche 14/10/2007 à 10:14

Didier

Salut à tout l'équipe de Viabloga et à tous les Viabloguers !

Félicitation pour le nouvel éditeur visuel !

Mais chez moi les icônes n'apparaissent pas correctement (je suis sous Firefox).

 

 

Qu'est-ce qui se passe?


Re: Icônes par leblase le Dimanche 14/10/2007 à 12:16

leblase

Es-tu en connexion haut débit?


Re: Icônes par Didier le Dimanche 14/10/2007 à 12:35

Didier

oui! 1 mega (orange).

Ce qui est étrange, c'est que sur V2V... Les icônes sont là !


Re: Icônes par isabelle le Dimanche 14/10/2007 à 13:26

isabelle

Je suis allé chez toi et j'ai eu le même type d'affichage que toi, sans les icônes. Le problème est soit au niveau même de ton blog, soit au niveau du modèle qui aurait des soucis avec cet éditeur. Donc, donc, y'a plus qu'à attendre le grand Sorcier !


Re: Icônes par Jean-Luc le Dimanche 14/10/2007 à 14:56

Jean-Luc

Bonjour Didier. Spectaculaire, l'évolution de ton site, bravo ! Tu pourrais prendre part aussi à la réflexions sur les revenus liés aux blogs et nous faire partager ton expérience car tu as manifestement adopté une stratégie de revenus via G.A.. Le sujet est manifestement devenu moins sensible qu'auparavant et je trouve cela plutôt sain.

Néanmoins j'interviens ici pour répondre à ton souci immédiat. J'ai testé, après Isabelle. Je pense que le problème provient de l'affichage de SiteSearch Google sur la page de création/modification des commentaires (et probablement des articles aussi).

Je ne sais pas pourquoi mais c'est obligé que ce soit cela. En fait, je pense que tu as mal placé le script de cette boîte de recherche G.A. : il faut l'insérer dans chaque objet (Sommaire, Articles, Textes) et pas au niveau de tout le site, pas si haut dans le body de ton modèle. Pour le vérifier, il te suffit de le supprimer où il est inséré actuellement dans ton modèle et ensuite tu le réintroduis progressivement dans chaque objet...


Re: Icônes par Didier le Dimanche 14/10/2007 à 18:01

Didier

Je vais suivre les bons conseils, merci.

Cependant, j'ai constaté que tout en gardant les blocs G A comme ils sont maintenant , l'affichage des icônes est impeccable dans  INTERNET EXPLORER!


Re: Icônes par Didier le Dimanche 14/10/2007 à 18:10

Didier

Après avoir retiré tous les blocs G A, les icônes ne s'affichent toujours pas :


Re: Icônes par Jean-Luc le Dimanche 14/10/2007 à 19:24

Jean-Luc

Ah, damned ! C'est pourtant nécessairement lié à ce qui est présent dans cette page de modification/création d'un commentaire puisque tu ne rencontres pas le problème avec Vie de Viabloga, toujours sous Firefox. Tu peux t'en assurer en revenant sur le modèle public juste le temps de tester. Il faut donc analyser en détail le code de la page avec ton modèle retouché par rapport au même affichage avec le code du modèle public, il y a nécessairement quelque chose qui ne va pas, comme c'était le cas pour Leblase avec le script de son service de stats tiers. Le fait qu'Internet Explorer soit plus tolérant dans ce cas n'est pas un gage de bonne conduite...


Re: Icônes par Didier le Dimanche 14/10/2007 à 19:33

Didier

Je veux bien... mais c'est quoi le modèle public? C'est ne pas m'identifier comme administrateur, c'est ça?

... Je suis pas vraiment un spécialiste informatique.


Re: Icônes par Jean-Luc le Dimanche 14/10/2007 à 21:13

Jean-Luc

Pardon, je croyais que tu avais personnalisé ton modèle. Donc, oublie mes recommandations précédentes.

En revanche, je viens de découvrir en consultant plus attentivement le code de ta page de création d'un commentaire (et j'utilise pourtant le même modèle), que les codes des blocs prévus pour s'afficher sur les pages Autres sont présents, même si ces blocs ne sont pas affichés lors de la création du commentaire. Je continue donc de soupçonner les scripts de G.A. car je ne vois pas de problèmes particuliers avec tes listes par ailleurs. Je te propose donc d'essayer de n'afficher tes 4 blocs libres qui contiennent ces scripts Google qu'en Première page

Menu administrateur > Mise en page > bouton 'Choisir les blocs'

et sur chaque ligne où tu as sélectionné un bloc libre tu sélectionnes Première page dans le menu déroulant de la colonne Pages.

Au moins cela permettra d'écarter ou de circonscrire le problème. Si le problème disparaît ce faisant, il suffira de les rétablir un par un en pages Toutes ou Autres pour savoir lequel est en cause, ou lesquels. Sinon il faudra regarder les autres blocs.


Re: Icônes par Didier le Dimanche 14/10/2007 à 21:19

Didier

C'est fait !

Mais je n'ai toujours pas les belles icônes sous FF !


Re: Icônes par Jean-Luc le Dimanche 14/10/2007 à 21:56

Jean-Luc

J'ai vu, Didier. J'ai beau chercher - et j'ai cherché ! - je ne vois pas d'autres pistes. Il ne te reste plus qu'à t'adresser au support officiel. En plus, c'est probablement quelque chose de tout bête. Si tu trouves, merci de nous en faire part ici, que je sache ce que je n'ai pas trouvé parce que je ne savais pas quoi ou comment chercher... En attendant, même si les icônes ne s'affichent pas correctement sous FF, elles sont quand même lisibles (ce qui est étrange, justement) et l'éditeur demeure donc exploitable par les 20 ou 30% de tes lecteurs qui utilisent ce navigateur.


Re: Icônes par Didier le Dimanche 14/10/2007 à 23:15

Didier

Question : Est-ce que mes visiteurs voient les mêmes icônes que moi?

Sinon, c'est vrai que tout fonctionne très bien... C'est juste pas très lisible. C'est dommage qu'il n'ay ait toujours pas de fonction "ajouter" dans le correcteur orthographique... Même le mot "blog"... il connaît pas. Le comble !

Je vais contacter Google demain et si j'ai la réponse je te la communiquerai.

Merci pour ton aide et bravo à toute l'équipe !


Re: Icônes par Jean-Luc le Dimanche 14/10/2007 à 23:35

Jean-Luc

Je te parlais en fait du support officiel de Viabloga ! Moi, je ne suis qu'un utilisateur comme toi, juste un peu plus expérimenté mais pas plus compétent techniquement...

Isabelle et moi voyons la même chose que toi sous Firefox, il doit donc en être de même pour les internautes qui utilisent ce navigateur (20 ou 30% des visiteurs de blogs). Quant aux Internet Exploreurs, tu disais que l'éditeur s'affiche correctement sous IE. Donc pas trop de souci à te faire.


Re: Icônes par Didier le Lundi 15/10/2007 à 18:12

Didier

Merci pour tout !

Stéphane est intervenu... tout est nickel !

 


Re: Icônes par Didier le Dimanche 14/10/2007 à 20:57

Didier

C'à fait pareil quand je me suis déconnecté comme "administrateur".


Re: Icônes par Stephane le Lundi 15/10/2007 à 11:50

Stephane

C'est corrigé, il y avait un problème de configuration de l'éditeur avec la plateforme zevillage.org.

 

 

 

 


Re: Icônes par Didier le Lundi 15/10/2007 à 18:09

Didier

Merci Stéphane ! Tout est rentré dans l'ordre... Un bel éditeur avec de belles icônes !

Ta réputation de grand sorcier se confirme une fois de plus !

Bravo Viabloga !


par iza le Dimanche 21/10/2007 à 22:41

Je reviens à peine parmi vous. vraiment désolée de vous avoir pollué ce post.
charmante entrée en matière, bien discrète comme je les aime ;-)
à bientôt


Re: par Jo le Lundi 22/10/2007 à 13:59

T'inquiète.
C'est pas si grave.

Bon j'te laisse, j'ai faim : le p'tit déj' est loin et j'ai pas de veau aux olives sous la main.


problème de quote par delphine f le Mercredi 07/11/2007 à 09:03

bonjour,

je rencontre un problème avec fckeditor. Lorsque j'insère du contenu, des liens hypertextes ou encore des images il me rajoute des quotes. lorsque j'étais en local cela ne posait pas de problème mais sur le serveur mutualisé du site il y a ce^problème si vous pouviez m'aider ça serait gentil de votre part.

merci

voici un exemple concret

Articulo en Los Tiempos



Session

Pour participer plus facilement, ouvrez une session :

Identifiant de
mon blog
Nom d'utilisateur
Mot de passe

Si vous avez déjà un blog sur ViaBloga ou si vous avez ouvert un compte sur l'un d'entre eux, vous pouvez vous identifier avec votre nom d'utilisateur et mot de passe en précisant d'abord l'identifiant de votre blog.

S'inscrire

Archives par mois