S'identifier - S'inscrire - Ecrire un article - Contact

Images pas sages

Par Didier • Aide • Samedi 20/10/2007 • 16 commentaires  • Lu 2940 fois • Version imprimable

Mots-clés :


On dit toujours "Sage comme une image"... et bien ce n'est plus le cas sur mon blog !!!!

http://didier-leveille.zevillage.org

A l'aide ! Vite ! URGENCE !!!
Mes images sont en pleine révolution anarchique depuis deux jours au moins... et sans avoir touché à quoi que ce soit dans mon blog...

Mes "vignettes" qui servent de liens dans ma galerie ont pris des proportions et des positions très inattendues... et surtout très moches.
Quand on clique sur une image pour l'agrandir... C'est une nouvelle page qui s'ouvre !!!!!

Faut faire quelque chose please !!! Et vite svp !!!!

Merci d'avance.

D'autres articles sur des thèmes similaires :


Commentaires

chambardement par leblase le Dimanche 21/10/2007 à 01:52

leblase Salut.
Tu as forcément touché à quelque chose. Je suis allé voir à l'intérieur de la page "illustrations" et c'est effectivement assez chaotique.. Même si j'ignore comment c'était avant ;-).
Je mets mon commentaire, principalement pour attirer l'attention d'un des gourous locaux car je suis trop court pour te conseiller, si vraiment tu n'as rien changé lors de ton dernier passage dans le menu Admin.


Re: chambardement par labosonic le Dimanche 21/10/2007 à 05:14

Non, Didier, n'a touché à rien.
Je pense plutôt que c'est du à un changement de l'éditeur visuel, parce que j'ai rencontré des petits soucis moi aussi. A priori, certaines anciennes instructions html générées par le vieil éditeur ne sont plus prises en compte correctement par le nouveau :

J'ai quelques cas génants (une cinquantaine maximum) comme ça et probablement plein d'autres pas génants (mais je ne peux pas dénombrer)

<img src=  ... style="width: 521px; height: 131px;"> ne s'affiche plus du tout correctement dans mon navigateur et reprend sa taille originelle. C'est d'autant plus génant que dans l'éditeur de texte, il s'affiche avec la taille qui est définie ... C'est à mon avis lié aux soucis plus ou moins évoqués . L'éditeur semble faire son boulot (donc on le voit dans l'éditeur) mais on dirait qu'un CSS repasse par dessus pour détruire ce qui est défini.

Je pensais être le seul à avoir ce souci et ne comptais pas forcément en faire une montagne (vu qu'en ce moment, je fais le grognon et que j'insiste déjà sur le fait qu'en cas de changement, c'est à la plateforme de garantir que l'ancien marche toujours avec le neuf) mais si ça se trouve, on est nombreux.

La solution que j'ai trouvé avec mes petits doigts sur mon clavier (pour Didier et avec un peu de patience s'il y a pas beaucoup de cas) :Effacer à la main la balise qui ne va pas ...

Editer l'article/texte où l'image n'est pas sage
Passer en mode source
Retrouver dans le code en question la partie qui commence par <img src=  ... style="width: nnnpx; height: mmmpx;"> où nnn et mmm sont des nombres.
Supprimer la partie en gras.
Repasser en mode Wysiwyg (éditeur classique).
On voit alors clairement dans l'éditeur l'image avec sa taille fantaisiste comme sur le blog.
On la redimensionne avec le nouvel éditeur. Et ça remarche ...
La solution pour que tout remarche nickel : (pour Stéphane)

La commande mal interprétée est du type :
<img src="..." alt="..." title="..." style="width:...px; height:...px;">

Il faudrait la remplacer par :
<img src="..." alt="..." title="..." width="..." height="...">

Il faudrait donc soit s'assurer que l'ancienne commande redevienne valide, soit remplacer toutes les occurences de l'un par l'autre partout.


Re: chambardement par Didier le Dimanche 21/10/2007 à 11:35

Didier Hou la la !!!!
Ça me dépasse un peu le code source, moi ! Et je suis autant surbooké que Leblase !!!
Alors, les manips avec les balises... C'est pas gagné !

Merci cependant pour ton intervention !!!!

Je voudrai quand même faire remarquer que ce "bug" est apparu bien après la mise en place du nouvel éditeur.
Et il reste encore à élucider le problème du "clic sur l'image" qui ouvre une nouvelle fenêtre... ça le fait aussi sur d'autres blogs que le mien ( http://photographe.zevillage.org ).

N'étant pas spécialiste du code source, crois-tu que je peux redimensionner les images à la main sans que ça bouleverse les balises ou je ne sais quoi d'autre dans la page ?

Merci beaucoup pour ton aide !


P.S. chambardement par Didier le Dimanche 21/10/2007 à 11:38

Didier Et non ! Pas moyen de redimensionner.... Dans l'éditeur visuel, la page est impécable !!!!!


Re: chambardement par leblase le Dimanche 21/10/2007 à 14:04

leblase
Labo,
Le chamboulement que tu évoques est plutôt  dérangeant, en effet. Du coup, je suis allé jeter un coup d'oeil sur un billet vieux de deux mois, mais ça allait.
Par contre, l'éditeur visuel (et l'épouvantable nécessité, pour les commentateurtrices habitués et non experts, de nettoyer le cache) semble causer quelques perturbations.
On me dit que les profils d'utilisateurs ,les mots de passe ne sont plus reconnus.
Il semble aussi que sur un autre site, doté (je viens de m'en rendre compte), d'un captcha (beurk), celui-ci ne reconnaît pas les lettres et chiffres mis en réponse.


Re: chambardement par Didier le Dimanche 21/10/2007 à 20:28

Didier Je suis pas assez calé pour tout comprendre, mais quand tu parles du profil... Je me rends compte que ma "trombine" n'apparaît pas dans dans mes comms...
Il y aurait-il un rapport?


Re: chambardement par isabelle le Dimanche 21/10/2007 à 17:17

isabelle j'ai eu ce problème avec une toute petite image mise en bloc de colonne qui avait repris sa taille d'origine : la petite colonne était devenue aussi large que celle des articles ! A force d'ouvrir l'éditeur pour revalider le texte, de la réduire à la main avec les coins, mais plusieurs fois, ça a fini par rentrer dans l'ordre sans que je comprenne trop ce que j'ai fait pour que ça marche. Mais sans que je tripatouille le code source...


Re: chambardement par Didier le Dimanche 21/10/2007 à 20:39

Didier Merci Isabelle pour ton témoignage et ton aide.

J'ai fait ça moi aussi, bien que dans l'éditeur tout était nickel, j'ai réduit manuellement, souris en main, la taille de mon image.
Le résultat dans l'article correspondait parfaitement.
Je suis retourné dans l'éditeur et j'ai remis l'image à la taille voulu... Visiblement ça marche !!!

Mais bon, faire ça pour chaque image va me prendre un temps fou !!!!
D'abord, faut que je visite tout mon blog pour trouver les images qui ne sont pas sages, puis les éditer une à une pour leur redonner leur taille.
Surtout qu'en parallèle, je suis confronté à un autre soucis... Quand je clique sur une image, c'est une nouvelle page principale qui s'ouvre.


Re: chambardement par Didier le Dimanche 21/10/2007 à 11:22

Didier Non seulement je n'ai touché à rien du tout... Mais ce phénomène chaotique ne date que de quelques jours (je m'en suis rendu compte jeudi 18)... et le nouvel éditeur visuel est installé depuis plus longtemps que ça.

Et puis il y a aussi le "clic sur image" qui ouvre une nouvelle page à la place de l'image elle-même !

merci quand -même pour ta brève intervention...



Re: chambardement par tgtg le Dimanche 21/10/2007 à 13:02

tgtg

Il y avait un problème de configuration de l'éditeur avec la plateforme zevillage.org.
Peut-être est-ce encore le cas?


Re: chambardement par Didier le Dimanche 21/10/2007 à 20:25

Didier C'est vrai que ça fait pareil sur les blogs d'autres Zevillageois...


test par Stephane le Dimanche 21/10/2007 à 15:47

Stephane


Images dans une nouvelle fenêtre par Stephane le Dimanche 21/10/2007 à 18:04

Stephane > Quand on clique sur une image pour l'agrandir... C'est une nouvelle page qui s'ouvre !!!!!

Celà a toujours été le cas, l'éditeur n'a rien changé.


Re: Images dans une nouvelle fenêtre par Didier le Dimanche 21/10/2007 à 20:24

Didier Je sais Stéphane... C'est une nouvelle page qui s'ouvre sur l'image.
Mais depuis quelques jours (je m'en suis rendu compte jeudi) c'est une nouvelle page principale qui s'ouvre!

Look : http://didier-leveille.zevillage.org/


Re: Images dans une nouvelle fenêtre par Stephane le Dimanche 21/10/2007 à 21:56

Stephane J'ai vu, c'est corrigé.


Re: Images dans une nouvelle fenêtre par Didier le Dimanche 21/10/2007 à 22:06

Didier GENIAL !

Bravo et merci Stéphane !



Session

Pour participer plus facilement, ouvrez une session :

Identifiant de
mon blog
Nom d'utilisateur
Mot de passe

Si vous avez déjà un blog sur ViaBloga ou si vous avez ouvert un compte sur l'un d'entre eux, vous pouvez vous identifier avec votre nom d'utilisateur et mot de passe en précisant d'abord l'identifiant de votre blog.

S'inscrire

Discussions actives (+ commentaire)


Archives par mois