S'identifier - S'inscrire - Ecrire un article - Contact

Editeur facétieux

Par Didier • Aide • Mardi 24/10/2006 • 24 commentaires  • Lu 2609 fois • Version imprimable

Mots-clés : ,


Captures d'écran à l'appui, voilà ce que je constate, depuis peu, dans mon éditeur visuel :

Un énorme décalage qui rend incontrôlable et aléatoire toute mise en page.

Voilà ce que je vois dans l'éditeur, après avec sélectionné mon texte et lui avoir appliqué de l'Arial 3. Mon texte reste inexorablement affiché en times 1...
... Et après avoir (en deux temps comme suggéré dans le commentaire de Jean-Luc) édité mon image pour qu'elle soit au Milieu :



Et voilà le résultat obtenu après validation sur la page de mon blog :



L'arial 3 est là, mais l'image n'est toujours pas centrée.
Ceci dit, c'est trop aléatoire de travailler ainsi.
Saut, ou passage à la ligne, habillage d'images, look global de la mise en page, la différence avec le résultat final ne permet absolument pas de soigner l'aspect de mon blog.

Frustre, frustre, frustre !!!!

D'autres articles sur des thèmes similaires :


Commentaires

Centrage de l'image par Stephane le Mardi 24/10/2006 à 16:15

Stephane Le plus simple c'est de sélectionner l'image et de cliquer sur le bouton "Centré" :



Re: Centrage de l'image par Didier le Mardi 24/10/2006 à 16:22

Didier Je vais essayé ça... Ça parait tellement logique !
Cependant, on m'a dit plusieurs fois, qu'il fallait retourner dans "Insérer image" pour régler son ajustement.


Re: Re: Centrage de l'image par Jean-Luc le Mardi 24/10/2006 à 16:37

Jean-Luc

on m'a dit plusieurs fois, qu'il fallait retourner dans "Insérer image" pour régler son ajustement.
Son ajustement par rapport au texte, pas pour la position dans la page !

Il n'y a d'ailleurs pas d'option de centrage dans le formulaire. 'Milieu' certainement pas, qui concerne la position du texte par rapport à l'image.

Encore une fois : as-tu consulté le tutoriel Présentation des images > Centrage dans l'article ? Cela me semble assez clair mais peut-être que la terminologie ne l'est pas assez.


Centrr une image par Didier le Jeudi 26/10/2006 à 00:47

Bien sur, tu penses bien que je l'ai consulté. La mise en page, vu le côté graphique de mon blog, est une de mes préoccupations principales depuis le début.
Au départ, nageant un peu, j'ai demandé conseil à Xavier. Puis très vite, j'ai fouillé dansl 'aide de Viabloga. C'est pas sorcier :" Faites comme ci, faites comme ça.
Mais dès fois... Ça ne marche pas !
Pas plus tard que tout à l'heure, j'ai publié un article. L'éditeur continue à être à côté de ses pompes.
Le curseur, quand il est présent, n'obéi à rien du tout. Quand je veux surligner un texte... Il applique la couleur sélectionnée au texte et non au fond du texte.. Et si ça c'est de l'arial 1 (8pt) au moment où j'écris, je veux bien être pendu ( comme on dit).

Vous me dites que c'est à cause de ma config. Moi je veux bien... Mais expliquez-moi!

J'ai visité ( au sens propre du terme) mon blog sur une autre bécane... Et bien c'est tout comme.
Cet éditeur contient des lacunes!

Et comme j'ai pu le lire au fil des commentaires : " Les utilisateurs lambda, comment font-ils ? "



 


Re: Centrr une image par Jean-Luc le Jeudi 26/10/2006 à 09:08

Jean-Luc Es-tu au moins parvenu à centrer ton image ?

Didier, cela ne fait pas avancer les choses de lancer comme ça des "ça ne marche pas !" si tu ne nous montres pas ou si tu ne nous expliques pas précisément ce qui n'a pas marché (qu'est-ce que tu voulais faire ?) et comment ça n'a pas marché (comment as-tu procédé précisément ?), que nous puissions essayons de comprendre ce qui se passe et, si possible, t'aider.

Maintenant si tu préfères balancer des sentences sur l'éditeur, là je ne pourrai pas t'aider.

Le curseur, quand il est présent, n'obéi à rien du tout.
Mais encore ?
" Les utilisateurs lambda, comment font-ils ? "
comme les autres : ils utilisent l'éditeur ! Tu crois que je m'ennuie avec la syntaxe html alors que je peux quasiment tout faire et tout obtenir à l'aide de l'éditeur ? L'éditeur permet au moins de mettre rapidement et simplement en forme, i.e. de générer la syntaxe html correspondante. Je t'invite d'ailleurs à être curieux et à aller observer ce qu'il fait quand tu lui demandes de faire quelque chose, il te suffit de passer au code source avec le bouton pour constater ce qu'il fait.

Je n'utilise pas tout non plus, c'est suivant les besoins de chacun. Je n'avais par exemple jamais utilisé le correcteur orthographique.

Ni le bouton de surlignage qui, effectivement, ne semble pas opérationnel. Je reporte à Stéphane pour qu'il regarde. Ou si quelqu'un a une idée.

Pour le reste, j'utilise toutes les fonctions de l'éditeur sans soucis particuliers, n'étaient ceux qu'on a pu déjà évoquer comme les boîtes qui ne se referment pas toutes seules aléatoirement mais rien de très préjudiciable, juste un peu agacant (et surtout incompréhensible, dans l'aléatoire).

Je ne dis pas non plus que cet éditeur est la panacée. De fait, Stéphane nous annonce depuis plusieurs mois son intention d'en changer. En attendant, je m'en sers !

Je te rappelle aussi que les valeurs indiquées pour la police et sa taille ne sont que les valeurs affichées par défaut des menus déroulants correspondants : ils ne présument en rien les paramètres par défaut du texte qui, eux, dépendent du modèle utilisé - à moins que tu ne leur appliques une autre valeur à l'aide de ces menus de l'éditeur !


Trés cher Jean-Luc par Dider le Vendredi 27/10/2006 à 01:13

Je suis désolé de ne pas être plus précis.
(Par contre ça marche beaucoup mieux aujourd'hui, je wisiwig ce que je tapes, c'est déjà un plus... Je suis revenu à Internet Explorer... J'ai presque honte!).

Le curseur que j'évoque dans mon commentaire précédent était tout bonnement inexistant. Pas moyen d'insérer du texte à l'endroit voulu, le curseur ayant ce rôle essentiel.

J'arrive à centrer les images, mais je n'ai pas encore eu le temps d'essayer de les habiller de textes. Mon prochain article en sera l'occasion.

Mais n'empêche que je me mets toujours dans la peau d'un quidam qui n'y connaîtrait que dalle en "informatique"... Pour lui, c'est pas gagné!

Ne vous bilez pas, tous autant que vous êtes, pour les bienfaits de votre éditeurs visuels.
Il n'en existe aucun autre, à ma connaissance et d'après ce que j'ai vu dans les autre blogs, aussi perfectionné que le votre... Il déconne un peu parfois, soit, mais quel outil génial et indispensable.

Aucun autre blog ne propose l'équivalent!

Moi, j'ai un peu de mal à le contrôler en ce moment, je l'avoue. Ça change d'une journée à l'autre... On fait avec... Et on sait que vous bossez dur derrière.

Alors... Merci Viabloga !!!


Trés cher Didier par Jean-Luc le Vendredi 27/10/2006 à 01:27

Jean-Luc

Mais n'empêche que je me mets toujours dans la peau d'un quidam qui n'y connaîtrait que dalle en "informatique"... Pour lui, c'est pas gagné!
Et si l'on s'épatait plutôt de tout ce que l'on parvient déjà à faire alors qu'on n'y connait vraiment rien en "informatique" ?! Certes, ce n'est pas toujours très accadémique dans la mise en oeuvre mais bon an mal an ça tient la route tout de même, non ?


Trés cher Jean-Luc par Dider le Samedi 28/10/2006 à 00:15

Bien sur que ça tient la route !

De tous les blogs que j'ai pu visiter, Viabloga, à mes yeux  reste le meilleur (éditeur compris, vu qu'ailleurs, ils sont inexistant ! ).

Je me rends tout à fait compte du boulot que ça doit représenter pour vous... Mais c'est votre passion, comme pour moi la peinture... Quand on aime on ne compte pas...

Mais, aujourd'hui un pourcentage énorme de la population utilise un ordinateur, surfe sur le web, et à l'occasion créé un blog.

Il n'ont pas tous comme moi, ou plutôt comme toi, piloté des 286 sous MS-DOS (sacré Bill Gates... sans lui où en serions-nous!)

Les "Utilisateurs" sont d'un autre cosme. Vous êtes des techniciens et le utilisateurs sont des utilisateurs (lambda).

Quand ils cliquent, il faut que ça clique...
Moi, je veux mon image au centre avec mon texte tout autour écrit avec cette police qui m'avait bien plu dans un parchemin du 13ème siècle à la bibliothèque nationale. (Je rigole) et je veux l'avoir dans l'instant. Sans avoir à me soucier de la machinerie... Vue qu'elle m'a coûtée quelques euros difficiles à éponger.

Bon, en gros, je m'aperçois que la technique reste un obstacle pour les non-initiés.

Tu sais à quoi je pense tout de suite : Il y à 30 ans, des hommes marchaient sur la Lune. Et je peux t'assurer que leurs ordinateurs fonctionnaient à merveille et sans l ' ADSL ou le WIMAX... Peut-être même sans Windows...

Par quel mercantilisme cette technologie ne nous est-elle pas parvenue.

Nous, on continue de bidouiller !


Re: Centrr une image par Jo le Jeudi 26/10/2006 à 15:10

Bonjour Didier,

Effectivement, cet éditeur contient de graves lacunes, principalement sous FireFox.
Je ne sais plus à qui (peut-être à toi) j'ai dit qu'en fait je ne rédige que sous IE et lis sous FF si il y a des soucis d'affichage.

Sous IE tu as une vraie différence entre aller à la ligne (maj+entrée) et changer de paragraphe (entrée).
Tu peux également surligner de façon non-aléatoire. ;-)
Ceci dit, même sous daubeIE il y a parfois des couaks, des changements intempestifs de police de caractères, etc...
C'est encore pire quand tu fais des copié-collé depuis d'autres applications (un traitement de texte, une page web,...). Jean-Luc m'avait donné un moyen radical d'arrêter le massacre quand ça par vraiment en vrille : copier ton texte dans le bloc-notes de windows (ça a pour effet de supprimer toute mise en forme), puis recopier le tout dans ton article (ou commentaire, ou texte) pour en refaire la mise en forme proprement.
Je l'applique encore de temps en temps.
Mais d'une manière générale, et cela est valable dans n'importe quel éditeur (y compris les plus grands traitements de texte (coucou billy)), une technique qui limite les surprises c'est de taper le texte "au kilomètre" et de ne faire la mise en forme qu'après. ca évite de trimballer des parasites en cours de frappe.

Comment font les utilisateurs lambda ?
Ils se débrouillent, j'imagine...
Et à voir la "propreté" de ton blog, je n'ai pas l'impression que tu te débrouilles si mal que ça. :-)


Editeur visuel par Didier le Jeudi 23/11/2006 à 20:04

Didier Un mois plus tard, m'y revoilà !
Après avoir suivi tous les conseils ( j'ai maintenant deux navigateurs avec lesquels je jongle - IE et Firefox) je n'arrive toujours pas à contrôler ma mise en page.
Un simple texte que je voudrais en italiques entre deux parenthèses... J'y arrive pas!

Je sélectionne mon texte, je lui applique la police, le corps et le style et quand je reviens sur ma page principale de mon blog... Que dalle!

Même si j'applique un surlignage sur mes liens, j'ai beau valider et valider, sur la page principale ça n'apparaît pas.
Autant dire que je fais ma mise en page à l'aveuglette.

Les gars, c'est trop complexe! A quand le wisywig ?


Re: Editeur visuel par Jo le Jeudi 23/11/2006 à 20:25

En (italique entre 2 parenthèses) comme ça ?


Re: Re: Editeur visuel par Didier le Jeudi 23/11/2006 à 20:46

Didier Exactement comme ça!
Alors?


Re: Re: Re: Editeur visuel par Jo le Jeudi 23/11/2006 à 21:06

2 possibilités et demie me viennent à l'esprit :

  1. tu as copié/collé ton texte depuis un traitement de texte et tu as des cochonneries qui trainent dans les balises. Une seule solution efficace, copier/coller dans le bloc-notes et retour pour exterminer tous les parasites.
  2. tu essaies d'appliquer une mise en forme à un lien (je ne suis pas sûre d'avoir bien compris) et là il est possible que la feuille de style (qui donne un aspect commun à tous les liens) ne te laisse pas modifier le style mais ça m'étonne un peu.
  3. tu as des problèmes de vue, passkeu dans ton dernier article j'en vois plein des schtruks en italique entre parenthèses... ;-)


Re: Editeur visuel par Jean-Luc le Jeudi 23/11/2006 à 21:31

Jean-Luc Voici comment s'affichent tes 3 derniers articles de ton sommaire sur mon navigateur :







Tu constateras que ta mise en page est correctement appliquée. S'il n'en est pas de même sur ton poste de travail, vois ta configuration.

Une suggestion pour t'assurer que l'éditeur a bien fait son "boulot" : quand tu es en mode "Modifier", avant d'utiliser une commande de l'éditeur tu passes en code source [] pour voir comment se présente ton code, tu cliques à nouveau sur [] pour revenir en mode texte, tu appliques ta commande et, avant de valider, tu cliques à nouveau sur [] pour voir comment se présente maintenant ton code et ce qu'a réalisé la commande de l'éditeur (qui ne fait que traduire en code html ta demande), tu dois donc constater l'insertion d'un code, tu en profites pour découvrir la syntaxe, puis [Valider] :
  • si le code était correctement inséré et que cela ne s'affiche pas, encore une fois : vois ta configuration !
  • si l'action de l'éditeur n'a aucune incidence sur le code, alors décris nous les problèmes distinctement, précisément.


Re: Re: Editeur visuel par Didier le Jeudi 23/11/2006 à 22:00

Didier Merci pour tes conseils, mais le code source, excuses-moi, c'est pas bien mon truc.
Chacun son métier.
Ce que je vois sur tes copies d'écrans c'est que l'image que j'ai centré... Tu ne la vois pas centrée.
Les textes en italiques, je n'arrive pas à les distinguer sur la copie d'écran, alors je la ferme!

L'important c'est que, dans mon job, la mise en page c'est very important. Pas le code source.
Peut-être suis-je trop exigeant, mais si chaque fois que je veux faire un petit effet (italiques ou corps gras) je dois appeler un spécialiste, je m'en sorts pas!

Ce qui m'intrigue le plus, c'est quand tu dis de vérifier ma config... Qu'est-ce que tu entends par là?


Re: Re: Re: Editeur visuel par Jean-Luc le Vendredi 24/11/2006 à 03:05

Jean-Luc La copie d'écran est automatiquement réduite, il faut donc cliquer pour voir l'image en entier, ensuite cela dépend de tes paramètres d'affichage : si l'image est encore plus grande que ta définition d'écran, le navigateur va à nouveau l'ajuster pour qu'elle tienne dans le cadre de ton navigateur et du coup elle pixellise mais le navigateur te propose de l'afficher dans sa taille d'origine (le pointeur se transforme en une loupe avec un +, il suffit donc de cliquer une nouvelle fois), avec des ascenseurs pour la parcourir.

Tu verras alors que les textes en italique sont bien restitués en italique.

Pour le centrage de l'image, c'est un peu plus compliqué : elle a effectivement été centrée mais pas avec le bon code, ou plutôt celui qui a été utilisé ne fonctionne pas avec ce modèle, il s'affiche correctement en brouillon mais pas une fois validé. Ce qui s'est passé, c'est que tu as inséré ton image dans un paragraphe, repéré dans le code entre les deux balises <p> et </p>, du coup le code de centrage est devenu <p align="center"> alors que le "bon" code serait <div align="center">. Tu peux le vérifier en ouvrant un nouveau brouillon et en insérant directement ton image à l'aide du bouton de l'éditeur graphique puis, une fois qu'elle est insérée, tu pointes l'image et pour la centrer, puis pour découvrir les code :

<div align="center"><img src="/images/Paysage_de_neige_t.jpg" /></div>
Et si tu valides ou l'enregistres en brouillon, tu verras que ton image est bien centrée.

Donc, dans ton article, il faut que tu modifies dans le code actuel :
<p align="center"><font size="3" face="times new roman,times,serif"><img hspace="0" border="0" src="/images/Paysage_de_neige_t.jpg" /><br /></font><font size="2" face="times new roman,times,serif">Paysage hivernal (esquisse) -acrylique sur bois 130 x 90.</font></p>
au moins ceci :
<div align="center"><font size="3" face="times new roman,times,serif"><img hspace="0" border="0" src="/images/Paysage_de_neige_t.jpg" /></a><br /></font><font size="2" face="times new roman,times,serif">Paysage hivernal (esquisse) -acrylique sur bois 130 x 90.</font></div>
Le code en vert peut être également supprimé car à quoi bon affecter une police à une image ?

Si je te donne toutes ces explications, c'est pour être pragmatique et que tu aies une solution immédiate pour obtenir le résultat que tu recherches. Maintenant, si tu ne veux absolument pas te mêler de code et si tu préfères attendre que quelqu'un se penche sur le modèle et trouve une solution qui fonctionne dans tous les cas sans accéder au code, libre à toi mais là je ne peux plus t'aider ni t'assurer que ça se fera ni dans quel délai...
L'important c'est que, dans mon job, la mise en page c'est very important. Pas le code source.
Tout ce que je peux te dire, c'est que ça ce n'est pas réaliste car aujourd'hui c'est encore partiellement incompatible : tu ne peux avoir cette exigence (très louable) sans mettre un peu les mains dans le cambouis.

C'est comme si j'avais des vélléités en matière de peinture mais que je me considère comme un peintre "lambda" et qu'à ce titre j'estime n'avoir absolument pas à me préoccuper de techniques de dessin, de perspectives, d'association de couleurs, d'apprentissages liés à chaque technique, de maîtrise des instruments, enfin tout ce que tu rapportes très bien sur ton site concernant ta pratique mais c'est normal car tu es un "pro". Chacun son métier, comme tu dis. Alors que pour moi, dont ce n'est pas le métier et qui n'ai pas non plus de temps à y consacrer, cela devrait être parfaitement "intuitif" et immédiat, et pour autant le résultat devrait être vraiment "pro" car je ne vais quand même pas présenter des daubes ! Si en plus je pouvais ne pas me salir les mains car je n'aime pas ça. Tu as une solution dans mon cas ? Est-ce que tu peux me garantir que je pourrai présenter rapidement quelque chose qui ait de la gueule ? Et à quelles conditions ? 5€ par mois maxi ? Ah bon, et on peut faire un essai sur un mois ? Avec un support ?

Et là tu cibles l'application en ligne mais pour y accéder à cette application il te faut bien un poste informatique (du matériel), une connexion internet, un systéme d'exploitation (les problèmes commencent !) et un navigateur, et tout cela doit fonctionner correctement, ensemble, avec un cahier des charges monstrueux, des paramètres dans tous les sens, des failles partout, et toi, simple utilisateur dont ce n'est pas le métier, aux manettes... Or il semble qu'il y ait quelques soucis avec ta config, dont celui relevé déjà par Stéphane avec l'insertion de liens suspects dans tes textes, rien à voir avec des mots-clés, ni a priori avec l'application, de ton fait ou non, il y en a encore deux dans ton dernier article :
<a href="/news/?go=car">cet</a>
<a href="/news/?go=employer">employer</a>
Ça vient d'où, ça ? Comment rédiges-tu tes articles : directement dans l'article ou autrement ? Stéphane semblait suspecter un virus, tu as regardé un peu cela ? Tu dois avoir aussi des problèmes de paramétrage des navigateurs, voire du système d'exploitation mais c'est difficile à dignostiquer comme ça, à distance, avec aussi peu de précisions - sinon que rien ne marche (traduction : ça ne marche pas comme tu le voudrais) - sans savoir ce que tu as ni ce que tu as fait (mais on sait bien que tu n'as rien fait, comme tout utilisateur "lambda" !)... Essaye de trouver un support !


Oh la la! Comme tu y vas! par Didier le Mardi 28/11/2006 à 21:33

Didier Bonjour Jean-Luc.
Tout d'abord merci pour votre aide et pour l'efficacité de Viabloga (j'en fais la promo tous les jours).
Je respecte votre travail, mais ne prends pas de si haut ma requête.
Peut-être ai-je été un peu trop cru en parlant de métier et tu as bien compris qu'elles étaient mes attentes.

Combien sommes-nous à utiliser un ordinateur aujourd'hui pour communiquer? (je veux bien une réponse).
Combien sommes-nous d'artistes-peintres?

Le média n'est pas le même, l'enjeu non plus.
N'importe qui utilise un ordinateur, mais pas tout le monde sait faire de la peinture...
(Alors, si tu veux t'y mettre, c'est avec plaisir que je te filerai les tuyaux techniques).

Mais revenons aux vrais moutons: Il y a plus de trente ans, des hommes marchaient sur la lune... Et là je peux t'assurer que leurs ordis marchaient superfiablement.
Aujourd'hui, sur cette planète, où le maître-mot est Internet., pour nous les lambda, c'est toujours l'âge de pierre.

Le cambouis... Soit! Je m'y coltine grâce à votre aide... Mais, malgré mes efforts, les résultats ne sont toujours pas satisfaisants et laborieuses sont les manips.

J'ai toujours de "gros" soucis de mise en pages. Pas pour les images, vous avez réglé le problème de manière géniale. Non juste un peu de présentation dans les textes... La base!

Vous me dites que ma config déconne. Je veux bien l'entendre, mais aidez-moi à savoir en quoi.
Vous me dites qu'il y a peut-être du virus dans l'air... Donnez-moi l'adresse d'un anti-virus (gratos de préférence).

Maintenant pour ce qui est de ces mots "bizarres" (comme tu as pu le constater)... Je n'y suis pour rien et je ne pourrais pas t'expliquer qu'elles manips j'ai pu faire vue que j'en ai fait aucune...

Aujourd'hui, j'ai publié un article sur mon blog. (parfois je les tapes directement dans l'article, mais cette fois-ci, j'ai d'abord enregistré dans un brouillon) :

Voilà une copie d'écran sous Firefox de ce que j'ai dans l'éditeur :



Voilà le résultat sur mon blog :



Je ne sais pas si ces captures d'écran sont déchiffrables, mais il est clair que ma mise en page n'est pas prise en compte.
Maintenant voilà la même sous IE :



... Et le résultat sur la page :



Incontrôlable, je te dis!

Et je vois pas bien en quoi les virus ont à faire avec cela.

J'admire ce que vous faites pour le bien de tous les Viablogueur. Je ne sais pas où est la soluce. Moi, j'arrive a entendre tes commentaires, je bricole et mets un peu les mains dans le cambouis... Je ne suis pas réticent.
Mais, une police, un corps gras, une italique ou je ne sais quoi... Même Worpad le fait.
Vous y êtes arrivé pour les images... Le chouette petit programme utile à tout le monde qui est le bien venu. De la lettre, de la simple simple lettre. Le plus petit dénominateur commun aux (combien) d'internautes.

Bon! Pour résumer. Si en tapant un article dans mon blog, vitrine pour mon job (métier), je n'arrive pas à mettre en gras ce que je veux (tu l'as bien perçu, c'est ma demande spécifique... Une mise page contrôlée) comment que je peux faire autrement, sinon qu'en soulevant le capot, pour voir où ça fuit.
Et même dans cet exemple imagé... IL faut que j'appelle un garagiste !

Je renouvelle mes félicitations, ma reconnaissance et le respect que j'ai pour votre engagement.

J'attends toutes tes suggestions (j'ai bien lu ton commentaire sur les codes source), je vais tâcher de l'appliquer.

J'ai juste besoin de taper un texte et de le retrouver dans ma page...

Merci pour tout!


Re: Oh la la! Comme tu y vas! par leblase le Mardi 28/11/2006 à 22:30

leblase Didier,

"...Donnez-moi l'adresse d'un anti-virus (gratos de préférence)."...

la réponse est :
http://www.01net.com/telecharger/windows/Securite/antivirus-antitrojan/fiches/25899.html

Gratuit et efficace


Lien par Didier le Mercredi 29/11/2006 à 22:43

Didier Merci pour le tuyaux !
Encore qu'il semblerait que je n'ai pas de problème avec les virus... Mais plutôt avec ma comprenette!


Re: Oh la la! Comme tu y vas! par Stephane le Mercredi 29/11/2006 à 01:19

Stephane Merci pour les détails et les captures d'écran, effectivement, il y a un problème.
J'ai compris ce qui se passe :
Dans l'éditeur, et dans l'éditeur seulement, mettre le texte en italique change, à l'affichage, la police de caractère... du coup, la police visualisée dans l'éditeur ne correspond plus à celle affichée ensuite une fois l'article validé.
Par contre je n'ai pas compris pourquoi celà arrivait, et je ne sais pas comment y remédier. :-(


Bon ! Bon! par Didier le Mercredi 29/11/2006 à 22:36

Didier Faut pas s'énerver non plus !
Je vais suivre tes recommandations, relever les manches et affronter le code source.
Mais je ne sais pas si j'en aurai vraiment le temps. 26000 visiteurs sont déjà passés sur mon blog depuis sa création fin février, 6000 rien que ce mois-ci.
Et si je le veux vivant, c'est maintenant plus de deux heures par jour que je lui consacre. Alors quand je vais soulever le capot. J'ai peur de passer plus de temps sur mon ordinateur que devant mon chevalet.

Tu as compris qu'il était devenu un outil de travail, une vitrine pour mon job, j'ai donc tout intérêt à ce que la mise en page soit nickel.

Alors va pour le code source... Je vais potasser!


Re: Re: Oh la la! Comme tu y vas! par Stephane le Mercredi 29/11/2006 à 23:51

Stephane

Pour revenir, et finir, avec ton article : ce qui s'affiche actuellement est strictement conforme au code (et la feuille de style du modèle)
Ce qui s'affiche _sur le blog_ est conforme au code. Ce qui s'affiche dans l'éditeur visuel ne l'est pas. CF mon commentaire d'au dessus. C'est très simple à voir : sur mon IE7 et sur mon Firefox, si je met un mot en italique, dans l'éditeur, la police change. C'est très bizarre. Ca doit être une histoire de police par défaut, je n'ai pas encore trouvé.


Re: Re: Re: Oh la la! Comme tu y vas! par Stephane le Jeudi 30/11/2006 à 00:15

Stephane En fait je pense que c'est effectivement du à la fonte par défaut de l'éditeur, qui était le Times New Roman, qui n'est pas la même que celle des commentaires (sur certains modèles). J'ai mis de l'Arial par défaut, je crois que celà correspond à plus de blogs.

En fait ce qu'il faudrait que je fasse, c'est dans chaque modèle, indiquer quels styles sont appliqués aux articles et commentaires, afin de pouvoir mettre ces mêmes styles par défaut dans l'éditeur.

Etape suivante bien sûr : rendre tous ces styles configurables depuis le menu mise en page, et faire en sorte que le style de l'éditeur soit toujours le même que celui des commentaires.


Re: Re: Re: Re: Oh la la! Comme tu y vas! par Jo le Jeudi 30/11/2006 à 15:13

Je me souviens de t'avoir parlé de ça un jour.
Dans mon daubeIE (avant la 7), la police par défaut de l'éditeur correspond à ce qui est affiché. Pas dans superFF.
J'ai moins de soucis parce que je n'utilise jamais la police par défaut et également parce que je ne change la police qu'une fois que j'ai quasiment tout écrit.
C'est effrayant le temps qu'on peut mettre parfois à identifier des pbs par comms interposés, alors qu'en présence ça prendrait 3 minutes et demie tout au plus.



Session

Pour participer plus facilement, ouvrez une session :

Identifiant de
mon blog
Nom d'utilisateur
Mot de passe

Si vous avez déjà un blog sur ViaBloga ou si vous avez ouvert un compte sur l'un d'entre eux, vous pouvez vous identifier avec votre nom d'utilisateur et mot de passe en précisant d'abord l'identifiant de votre blog.

S'inscrire

Discussions actives (+ commentaire)


Archives par mois