S'identifier - S'inscrire - Ecrire un article - Contact

Bug affichage image dans Firefox 2.0 ?

Par Nikita Calvus-Mons • Aide • Mercredi 12/12/2007 • 4 commentaires  • Lu 3150 fois • Version imprimable

Mots-clés : ,


Chers amis, un bug étonnant apparaît de temps en temps (quand même souvent disons, une fois sur 3 ou 4), de manière apparemment aléatoire, sur l'affoichage des images sur mon blog.

Uniquement sur Firefox. Exemple ci-dessous :

Normalement, il ya  une image de la taille du bloc laissé vierge. D'ailleurs on voit bien qu'elle n'est pas cassée. Mais elle ne s'affiche pas, et en cas de présence d'un "alt", celui-ci s'affiche en haut à gauche du bloc.

Je ne comprends rien du tout (si j'affiche le code source, il appelle correctement l'image). Si je recharge, parfois ça affiche l'image, parfois il faut plutôt que je clique sur le titre, bref ça a l'air aléatoire. Mais uniquement présent sur Firefox (version 2.0, sur WinXP famille 2002).

Le seul truc, c'est que le générateur des pages ajoute un attribut "title" dans le tag img, et que celui-ci est collé à l'attribut suivant. Est-ce que ça peut être ça, le souci ?

Ci-dessous, le bout de code (double espace avant title, aucun après...). Mais je ne pense pas que ça soit ça, vu que quand l'image s'affiche, le code est le même.



NB : sous Firefox, chez moi, cet article précis n'affiche pas sa première image... Kafkaïen ! (Et en effet c'est souvent la première image du code qui est touchée. Mais parfois également l'image contenue dans un bloc libre HTML... dont le code n'est pourtant pas touché par le générateur de pages...)

D'autres articles sur des thèmes similaires :


Commentaires

Espace mal placé par Stephane le Mercredi 12/12/2007 à 21:59

Stephane J'ai corrigé le problème de l'espace à tout hasard.


par OlivierMG le Mercredi 12/12/2007 à 22:02

OlivierMG Peut-être à cause d'une fonction de bloquage de pub ? (si l'image a une taille à peu près equivalente à celle d'un format de pub)


Re: par 60millions le Jeudi 13/12/2007 à 18:58

Non, c'est trop aléatoire, et puis ça n'a jamais vraiment la forme d'une pub, et puis je n'ai pas de bloqueur de pub ;-)

EN fait j'ai quand même l'impression que ça date d'après le nouvel éditeur visuel.

Cela dit Steph (tu permets ?), aujlurd'hui dans cet article l'image s'est affichée chez moi, peut-être que l'espace posait effectivement un pb. Je vais faire des reload successifs pour voir...


Re: par 60millions le Jeudi 13/12/2007 à 18:58

Non, toujours ce foutu bug. Il suffit que je reload et hop, l'image saute.



Session

Pour participer plus facilement, ouvrez une session :

Identifiant de
mon blog
Nom d'utilisateur
Mot de passe

Si vous avez déjà un blog sur ViaBloga ou si vous avez ouvert un compte sur l'un d'entre eux, vous pouvez vous identifier avec votre nom d'utilisateur et mot de passe en précisant d'abord l'identifiant de votre blog.

S'inscrire

Ailleurs sur ViaBloga

Derniers weblogs mis à jour :

17:14 - Le Glob
16:34 - La ballade d'un tête en l'air
16:15 - L'écho de CORNECUL
16:14 - OREEAT
13:27 - Asnières-sur-mon-blog
13:05 -
09:27 - Philosophie et politique
08:51 - Everitouthèque
08:50 - Voleur d'âme
21:22 - CADEV

Toutes les mises à jour

Archives par mois