S'identifier - S'inscrire - Ecrire un article - Contact

Problème d'affichage d'image sous Internet Explorer

Par isabelle • Aide • Jeudi 22/01/2009 • 12 commentaires  • Lu 6572 fois • Version imprimable

Mots-clés : , ,


J'ai un problème d'affichage pour une image en première page de ce site en construction, uniquement sous Internet Explorer sous Windows. Tout roule sous Mac, Safari et Firefox, y compris Firefox sous Windows. Et ça n'est que pour cette image-là du premier article. J'ai eu beau l'effacer, la retélécharger, rien n'y fait. Je ne sais pas si d'autres ont rencontré déjà ce même problème...

D'autres articles sur des thèmes similaires :


Commentaires

par Stephane le Vendredi 23/01/2009 à 10:42

Stephane C'est le JPEG qui est bizarre, essaie d'utiliser un autre logiciel pour le sauver.


bizarre? Vous avez dit bizarre? par leblase le Vendredi 23/01/2009 à 12:35

leblase Comment ça bizarre?
Sur Photoshop elle ne présente pas de bizarrerie.


Re: bizarre? Vous avez dit bizarre? par Stephane le Vendredi 23/01/2009 à 13:06

Stephane Il y a tout un paquet de façons différentes d'encoder une image jpeg, et j'imagine que celle là a été encodée avec une option exotique qui ne passe pas avec tous les logiciels. Par exemple il y a des logiciels qui ne supportent pas les JPEG progressifs.

En l'occurence, pour cette image, il y a un problème avec les couleurs avec l'aperçu de windows, un autre problème de couleurs avec quicktime sur windows, et effectivement elle ne s'affiche pas du tout avec Internet Explorer 7.

Donc la solution simple, c'est d'ouvrir l'image et de la resauver/réexporter avec un logiciel quelconque, en ne spécifiant pas d'options bizarres pour le format JPEG. Et ca marche :

Avant: (ne passe pas dans Internet Explorer)



Après: (passe partout)



Curieusement rien qu'en ouvrant l'image et en la resauvant avec Paint, les couleurs ne sont plus les mêmes. Celles de la version d'origine ont l'air truandées pour faire plus vert et plus ensoleillé d'ailleurs. (on se croirait à Chamonice ! tout le monde sait que la Sarthe c'est gris et pollué pourtant ;-)

Au pif je dirais que l'image d'origine intégre une transformation des couleurs (cf http://en.wikipedia.org/wiki/Jpeg#Color_profile : "Many JPEG files embed an ICC color profile (color space). Commonly used color profiles include sRGB and Adobe RGB. Because these color spaces use a non-linear transformation, the dynamic range of an 8-bit JPEG file is about 11 stops. However, many applications are not able to deal with JPEG color profiles and simply ignore them.") qui confuse complètement Internet Explorer et que Windows Paint ignore.


Re: bizarre? Vous avez dit bizarre? par leblase le Vendredi 23/01/2009 à 13:13

leblase Héhé, insinuerais-tu qu'IE n'est pas parfait?
Mais isabelle peut reprendre l'image qui passe sous IE et, si elle dispose de Photoshop (ou autre), augmenter la saturation des couleurs afin de continuer à nous faire croire que la Sarthe se situe entre Nice et Hawai;-)


Re: bizarre? Vous avez dit bizarre? par isabelle le Vendredi 23/01/2009 à 23:31

isabelle C'est ça, c'est ça... Entre Nice et Hawaï !! Mon bon Leblase, il faudrait revoir ta géolocalisation : ici on surfe entre la banquise, les orsbottes de Matignon, la naissance de la métaplastique et une sobriété généreuse :-)


J'ai trop fait la lessive par isabelle le Dimanche 25/01/2009 à 16:00

isabelle Tu disais quoi pour l'exotisme de couleurs ?


Lavoir lagon


Re: J'ai trop fait la lessive par Jean-Luc le Dimanche 25/01/2009 à 16:14

Jean-Luc Ouhlala, comment tant d'eau dans "notre" lavoir et comment cette couleur lactée ?!


Re: J'ai trop fait la lessive par isabelle le Dimanche 25/01/2009 à 16:55

isabelle Il faut que tu pousses ta petite promenade dominicale jusqu'au village :-)


Re: bizarre? Vous avez dit bizarre? par isabelle le Vendredi 23/01/2009 à 23:08

isabelle  Pffit ! Vous zy comprenez rien à la campagne, d'abord !!


Recommandé par des Influenceurs


Re: bizarre? Vous avez dit bizarre? par leblase le Vendredi 23/01/2009 à 23:12

leblase La Campagne? C'est ce machin où les rues ont pas d'immeubles?


Re: par leblase le Vendredi 23/01/2009 à 12:58

leblase Je remarque juste qu'elle est un peu lourde


Lien croisé par Visiteur le Dimanche 24/05/2009 à 18:35

blog de village - Asnières sobrement : "Problème d'affichage d'image sous Internet Explorer : "banquise, les orsbottes de Matignon, la naissance de la métaplastique et une sobriété généreuse :-) " "



Session

Pour participer plus facilement, ouvrez une session :

Identifiant de
mon blog
Nom d'utilisateur
Mot de passe

Si vous avez déjà un blog sur ViaBloga ou si vous avez ouvert un compte sur l'un d'entre eux, vous pouvez vous identifier avec votre nom d'utilisateur et mot de passe en précisant d'abord l'identifiant de votre blog.

S'inscrire

Ailleurs sur ViaBloga


Archives par mois