S'identifier - S'inscrire - Ecrire un article - Contact

Trappe sélective

sur influenceurs.net

Par Jean-Luc • Aide • Jeudi 21/08/2008 • 4 commentaires  • Lu 1885 fois • Version imprimable


Les articles des propositions antérieures au 28 Juillet 2006 ont "perdu" l'url de l'image de la bannière (un champ personnalisé). Du coup, logiquement, le code à copier/coller ne s'affiche plus. Ce qui me rassure un peu, c'est que cela ne concerne que les articles seuls. En Sommaire, ils s'affichent correctement. Pourquoi que ces articles et que les articles ? Je n'en sais rien. Et depuis quand ? Je l'ignore également, au moins depuis le 8 août si je me fie au cache de Google.
Est-il possible de récupérer les url concernées et de refermer cette trappe ?

PS : le serveur #2 ne semble pas au mieux de sa forme en ce moment...

Commentaires

par Stephane le Jeudi 21/08/2008 à 13:51

Stephane Si tu fais modifier l'article, tu vois le champ et sa valeur normale ?

Quel est le nom exact du champ ?

Pas de problème avec les autres champs ? Tu n'as pas renommé des champs il y a 2 ans ?


Re: par Jean-Luc le Jeudi 21/08/2008 à 20:29

Jean-Luc Si je fais Modifier, je ne vois plus rien dans ce champ personnalisé custom_image_url


pourquoi je parle de trappe
et cela ne concerne que ce champ, pour ce que j'ai pu vérifier,
et que la valeur du champ est toujours présente, quelque part, puisque la bannière s'affiche correctement en Sommaire
et que l'url est bien reprise dans le code, toujours en Sommaire,
pas dans l'affichage de l'article seul
pour les articles antérieurs au 28 Juillet 2006, suivant ce que j'ai observé.

J'ai peut-être effectivement modifié il y a 2 ans les descriptions, voire les attributs ou leur ordre, mais en m'assurant que cela fonctionnait, et régulièrement depuis.

Une piste ? Un dignostic ? Une perspective de rétablissement ?!


Re: par Stephane le Jeudi 21/08/2008 à 21:15

Stephane Pour cet article, l'image est dans image_url (image associée à un article), custom_image_url est vide. Il doit y avoir un bug dans la skin.


Re: par Jean-Luc le Vendredi 22/08/2008 à 08:59

Jean-Luc J'aurais pu effectivement y penser ! Mais je n'ai pas touché à ce skin, en tout cas à cette partie, depuis des lustres.

J'ai inséré le test suivant dans chaque object class=summary et class=news :

<if_attribute custom_image_url==>
<p>image interne <attribute image_url></p>
</if_attribute>
Le souci semble provenir de ce que object class=news ne restitue pas <attribute image_url>, contrairement à summary.

A partir de là, je ne vois pas ce que je peux faire - à part reprendre toutes ces image_url dans custom_image_url mais il y en a trop, j'avais déjà renoncé à le faire à l'époque.

Question, en passant : est-il possible de rétablir la ressource de cette image interne dans le formulaire d'influenceurs.net ou est-ce incompatible avec le formulaire personnalisé ?



Session

Pour participer plus facilement, ouvrez une session :

Identifiant de
mon blog
Nom d'utilisateur
Mot de passe

Si vous avez déjà un blog sur ViaBloga ou si vous avez ouvert un compte sur l'un d'entre eux, vous pouvez vous identifier avec votre nom d'utilisateur et mot de passe en précisant d'abord l'identifiant de votre blog.

S'inscrire

Ailleurs sur ViaBloga


Archives par mois